interval_intersection-0.10.14.ebuild 799 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/calibration"
  5. KEYWORDS="~amd64 ~arm"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. CATKIN_HAS_MESSAGES=yes
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="
  16. dev-libs/boost:=[threads]
  17. dev-ros/actionlib
  18. dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  19. dev-ros/rosconsole
  20. dev-ros/roscpp
  21. dev-ros/roscpp_serialization
  22. dev-ros/rostime
  23. "
  24. DEPEND="${RDEPEND}
  25. test? ( dev-cpp/gtest )"
  26. PATCHES=( "${FILESDIR}/gcc6.patch" )