kdl_parser-1.12.7.ebuild 547 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/robot_model"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Constructs a KDL tree from an XML robot representation in URDF"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-libs/boost:=
  15. dev-ros/roscpp
  16. dev-ros/rosconsole
  17. dev-ros/urdf
  18. sci-libs/orocos_kdl
  19. dev-libs/tinyxml
  20. "
  21. DEPEND="${RDEPEND}
  22. test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"