qt_dotgraph-0.3.0.ebuild 552 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
  5. KEYWORDS="~amd64"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="Helpers to work with dot graphs"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. media-gfx/pydot[${PYTHON_USEDEP}]
  15. >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
  16. "
  17. DEPEND="${RDEPEND}
  18. test? (
  19. dev-python/nose[${PYTHON_USEDEP}]
  20. dev-python/pygraphviz[${PYTHON_USEDEP}]
  21. )"