rosconsole-1.12.6.ebuild 789 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=tools/${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="ROS console output library"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE="+log4cxx glog"
  12. RDEPEND="
  13. dev-ros/cpp_common
  14. dev-ros/rostime
  15. dev-ros/rosunit
  16. dev-libs/boost:=[threads]
  17. log4cxx? ( dev-libs/log4cxx )
  18. !log4cxx? ( glog? ( dev-cpp/glog ) )
  19. "
  20. DEPEND="${RDEPEND}"
  21. src_configure() {
  22. local ROSCONSOLE_BACKEND=""
  23. if use log4cxx; then
  24. ROSCONSOLE_BACKEND="log4cxx"
  25. elif use glog; then
  26. ROSCONSOLE_BACKEND="glog"
  27. else
  28. ROSCONSOLE_BACKEND="print"
  29. fi
  30. local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
  31. ros-catkin_src_configure
  32. }