rostopic-9999.ebuild 566 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=tools/${PN}
  7. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  8. inherit ros-catkin
  9. DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/rosbag[${PYTHON_USEDEP}]
  15. dev-ros/rospy[${PYTHON_USEDEP}]
  16. "
  17. DEPEND="${RDEPEND}
  18. test? (
  19. dev-ros/rostest[${PYTHON_USEDEP}]
  20. dev-python/nose[${PYTHON_USEDEP}]
  21. )
  22. "