rqt_graph-0.4.6.ebuild 820 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KEYWORDS="~amd64"
  5. ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-python/rospkg[${PYTHON_USEDEP}]
  15. dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
  16. dev-ros/rosgraph[${PYTHON_USEDEP}]
  17. dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  18. dev-ros/roslib[${PYTHON_USEDEP}]
  19. dev-ros/rosnode[${PYTHON_USEDEP}]
  20. dev-ros/rospy[${PYTHON_USEDEP}]
  21. dev-ros/rosservice[${PYTHON_USEDEP}]
  22. dev-ros/rostopic[${PYTHON_USEDEP}]
  23. dev-ros/rqt_gui[${PYTHON_USEDEP}]
  24. dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
  25. "
  26. DEPEND="${RDEPEND}"