rqt_top-0.3.13.ebuild 532 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KEYWORDS="~amd64"
  5. ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="RQT plugin for monitoring ROS processes"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-python/psutil[${PYTHON_USEDEP}]
  15. dev-ros/rospy[${PYTHON_USEDEP}]
  16. dev-ros/rqt_gui[${PYTHON_USEDEP}]
  17. dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}"