tf2_kdl-0.5.13.ebuild 581 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/geometry_experimental"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="KDL binding for tf2"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-cpp/eigen:3
  15. dev-ros/tf2
  16. dev-ros/tf2_ros
  17. dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
  18. sci-libs/orocos_kdl
  19. dev-ros/tf2_msgs[${PYTHON_USEDEP}]
  20. dev-ros/cmake_modules
  21. "
  22. DEPEND="${RDEPEND} test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"