mysqltcl-3.05.ebuild 660 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils multilib
  5. DESCRIPTION="TCL MySQL Interface"
  6. HOMEPAGE="http://www.xdobry.de/mysqltcl/"
  7. SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
  8. LICENSE="HPND"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ~sparc x86"
  11. IUSE=""
  12. DEPEND="
  13. dev-lang/tcl:0
  14. >=virtual/mysql-4.1"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${P}-ldflags.patch
  18. sed -i 's/-pipe//g;s/-O2//g;s/-fomit-frame-pointer//g' configure || die
  19. }
  20. src_configure() {
  21. econf --with-mysql-lib=/usr/$(get_libdir)/mysql
  22. }
  23. src_install() {
  24. default
  25. dohtml doc/mysqltcl.html
  26. }