tkTheme-1.0-r2.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils eutils toolchain-funcs
  5. DESCRIPTION="Tcl/Tk Theming library"
  6. HOMEPAGE="http://www.xmission.com/~georgeps/Tk_Theme/other/"
  7. SRC_URI="http://www.xmission.com/~georgeps/Tk_Theme/other/${PN}.tgz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ppc x86"
  11. IUSE="debug examples static-libs threads"
  12. DEPEND="
  13. dev-lang/tk
  14. x11-libs/libX11
  15. x11-libs/libXext
  16. x11-libs/libXmu
  17. x11-libs/libXpm"
  18. RDEPEND="${DEPEND}"
  19. S="${WORKDIR}"/${PN}
  20. PATCHES=(
  21. "${FILESDIR}"/${PV}-Makefile.in.diff
  22. "${FILESDIR}"/${PV}-configure.diff
  23. "${FILESDIR}"/${PV}-cflags.patch
  24. )
  25. src_configure() {
  26. tc-export CC
  27. local myeconfargs=(
  28. --with-tcl="${EPREFIX}/usr/$(get_libdir)"
  29. --with-tk="${EPREFIX}/usr/$(get_libdir)"
  30. --with-x
  31. $(use_with debug symbols)
  32. $(use_enable threads)
  33. )
  34. autotools-utils_src_configure
  35. }
  36. src_install() {
  37. autotools-utils_src_install
  38. insinto /usr/share/${PN}
  39. use examples && doins -r demo
  40. }