tkpng-0.9.ebuild 692 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_P="${PN}${PV}"
  5. DESCRIPTION="Implements support for loading and using PNG images with Tcl/Tk"
  6. HOMEPAGE="http://www.muonics.com/FreeStuff/TkPNG/"
  7. SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tgz"
  8. SLOT="0"
  9. LICENSE="tcltk"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug threads"
  12. RDEPEND="
  13. >=dev-lang/tcl-8.4:0=
  14. >=dev-lang/tk-8.4:0=
  15. sys-libs/zlib"
  16. DEPEND="${RDEPEND}"
  17. # test target in Makefile, but test not shipped
  18. RESTRICT="test"
  19. S="${WORKDIR}"/${MY_P}
  20. src_configure() {
  21. econf \
  22. $(use_enable debug symbols) \
  23. $(use_enable amd64 64bit) \
  24. $(use_enable threads)
  25. }