dvi2gr-0.4.ebuild 890 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. DESCRIPTION="DVI to Grace translator"
  5. HOMEPAGE="http://plasma-gate.weizmann.ac.il/Grace/"
  6. SRC_URI="ftp://plasma-gate.weizmann.ac.il/pub/grace/src/devel/${P}.tar.gz"
  7. SLOT="0"
  8. LICENSE="GPL-2"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="examples"
  11. DEPEND="media-libs/t1lib"
  12. RDEPEND="${DEPEND}"
  13. src_prepare() {
  14. # respect flags
  15. sed -i \
  16. -e '/^LDFLAGS/d' -e '/^CFLAGS/d' -e '/^CC/d' \
  17. Makefile || die
  18. sed -i -e 's/DVI2GR=\.\/dvi2gr/DVI2GR=$(which dvi2gr)/g' runtest.sh || die
  19. }
  20. src_install() {
  21. dobin ${PN} || die
  22. if use examples; then
  23. insinto /usr/share/doc/${PF}/examples
  24. doins *.ti runtest.sh || die
  25. fi
  26. insinto /usr/share/${PN}
  27. doins -r fonts || die
  28. }
  29. pkg_postinst() {
  30. einfo "Don't forget install the TeX-Fonts in Grace"
  31. einfo " /usr/share/${PN}/fonts/FontDataBase"
  32. }