spacearyarya-kxl-1.0.2-r2.ebuild 835 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils
  5. MY_P=SpaceAryarya-KXL-${PV}
  6. DESCRIPTION="A 2D/3D shooting game"
  7. HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
  8. SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE=""
  13. DEPEND="dev-games/KXL"
  14. RDEPEND="${DEPEND}
  15. media-fonts/font-adobe-100dpi
  16. media-fonts/font-bitstream-100dpi"
  17. S=${WORKDIR}/${MY_P}
  18. PATCHES=(
  19. "${FILESDIR}"/${P}-gentoo-paths.patch
  20. "${FILESDIR}"/${P}-flags.patch
  21. "${FILESDIR}"/${P}-clang.patch
  22. )
  23. src_prepare() {
  24. default
  25. mv configure.{in,ac}
  26. rm aclocal.m4
  27. eautoreconf
  28. }
  29. src_install() {
  30. default
  31. newicon bmp/enemy1.bmp ${PN}.bmp
  32. make_desktop_entry spacearyarya SpaceAryarya /usr/share/pixmaps/${PN}.bmp
  33. }