c++robots-0-r1.ebuild 619 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
  5. HOMEPAGE="http://www.gamerz.net/c++robots/"
  6. SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~x86 ~ppc"
  10. IUSE="static"
  11. S=${WORKDIR}/${PN}
  12. PATCHES=(
  13. "${FILESDIR}/proper-coding.patch"
  14. )
  15. src_compile() {
  16. local myldflags="${LDFLAGS}"
  17. use static && myldflags="${myldflags} -static"
  18. emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
  19. }
  20. src_install() {
  21. dobin combat cylon target tracker
  22. dodoc README
  23. }