wumpus-1.4-r1.ebuild 986 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Classic Hunt the Wumpus Adventure Game"
  6. HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/src/games/wump/"
  7. SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/games/wump/wump.c
  8. ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/games/wump/wump.6
  9. ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/games/wump/wump.info"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~x86"
  13. IUSE=""
  14. DEPEND="sys-apps/less"
  15. RDEPEND=${DEPEND}
  16. S=${WORKDIR}
  17. src_unpack() {
  18. cp "${DISTDIR}"/wump.{info,c,6} "${S}/" || die
  19. }
  20. src_compile() {
  21. touch pathnames.h
  22. [ -z "${PAGER}" ] && PAGER=/usr/bin/less
  23. $(tc-getCC) ${LDFLAGS} -Dlint -D_PATH_PAGER=\"${PAGER}\" \
  24. -D_PATH_WUMPINFO=\"/usr/share/${PN}/wump.info\" ${CFLAGS} \
  25. -o wump wump.c || die
  26. }
  27. src_install() {
  28. dobin wump
  29. doman wump.6
  30. insinto /usr/share/${PN}
  31. doins wump.info
  32. }