hangman-0.9.2.ebuild 756 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="The classic word guessing game"
  6. HOMEPAGE="http://www.shiftygames.com/hangman/hangman.html"
  7. SRC_URI="http://www.shiftygames.com/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~sparc x86"
  11. IUSE=""
  12. DEPEND="!games-misc/bsd-games
  13. media-libs/libsdl
  14. media-libs/sdl-mixer
  15. media-libs/sdl-image
  16. media-libs/sdl-ttf"
  17. RDEPEND="${DEPEND}
  18. sys-apps/miscfiles"
  19. src_prepare() {
  20. sed -i \
  21. -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
  22. src/hangman.c \
  23. || die "sed failed"
  24. }
  25. src_install() {
  26. default
  27. newicon pics/noose.png ${PN}.png
  28. make_desktop_entry ${PN} Hangman
  29. prepgamesdirs
  30. }