gamepick-0.35-r1.ebuild 597 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Launch opengl games with custom graphic settings"
  6. HOMEPAGE="http://www.rillion.net/gamepick/index.html"
  7. SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. default
  17. sed -i \
  18. -e 's/-O2//' \
  19. src/Makefile.in || die
  20. }
  21. src_install() {
  22. default
  23. newicon ${PN}-48x48.xpm ${PN}.xpm
  24. make_desktop_entry ${PN} ${PN}
  25. }