gamepick-0.35.ebuild 759 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Launch opengl games with custom graphic settings"
  6. HOMEPAGE="http://www.rillion.net/gamepick/index.html"
  7. SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. sed -i \
  17. -e "s:/etc:${GAMES_SYSCONFDIR}:" \
  18. src/gamepick.h || die
  19. sed -i \
  20. -e 's/-O2//' \
  21. src/Makefile.in || die
  22. }
  23. src_install() {
  24. default
  25. dodir "${GAMES_SYSCONFDIR}"
  26. touch "${D}/${GAMES_SYSCONFDIR}"/${PN}.conf
  27. newicon gamepick-48x48.xpm ${PN}.xpm
  28. make_desktop_entry ${PN} ${PN}
  29. prepgamesdirs
  30. }