gnome-desktop-2.32.1-r2.ebuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="yes"
  5. GNOME2_LA_PUNT="yes"
  6. GNOME_TARBALL_SUFFIX="bz2"
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit gnome2 python-r1
  9. DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
  10. HOMEPAGE="https://www.gnome.org/"
  11. LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
  12. SLOT="2"
  13. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  14. IUSE="license-docs"
  15. # Note: gnome-desktop:2 and :3 install identical files in /usr/share/gnome/help
  16. # and /usr/share/omf when --enable-desktop-docs is passed to configure. To avoid
  17. # file conflict and pointless duplication, gnome-desktop:2[doc] will simply use
  18. # the files that are installed by :3[doc]
  19. # Note: depend on glib-2.34 to make sure users upgrade glib before gnome-desktop
  20. # to get a fix for bug #450930
  21. RDEPEND=">=x11-libs/gtk+-2.18:2
  22. >=dev-libs/glib-2.34:2
  23. >=x11-libs/libXrandr-1.2
  24. >=gnome-base/gconf-2:2
  25. >=x11-libs/startup-notification-0.5
  26. ${PYTHON_DEPS}
  27. "
  28. DEPEND="${RDEPEND}
  29. dev-util/gtk-doc-am
  30. >=dev-util/intltool-0.40
  31. virtual/pkgconfig
  32. >=app-text/gnome-doc-utils-0.3.2
  33. ~app-text/docbook-xml-dtd-4.1.2
  34. x11-proto/xproto
  35. >=x11-proto/randrproto-1.2
  36. "
  37. PDEPEND=">=dev-python/pygtk-2.8:2[${PYTHON_USEDEP}]
  38. >=dev-python/pygobject-2.14:2[${PYTHON_USEDEP}]
  39. license-docs? ( gnome-base/gnome-desktop:3[doc(+)] )
  40. "
  41. # Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
  42. # Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
  43. # eventually libXrandr shouldn't RDEPEND on randrproto)
  44. src_prepare() {
  45. epatch "${FILESDIR}"/${P}-gold.patch
  46. epatch "${FILESDIR}"/${P}-thumbnails.patch #450930
  47. gnome2_src_prepare
  48. }
  49. src_configure() {
  50. python_export_best
  51. gnome2_src_configure \
  52. --with-gnome-distributor=Gentoo \
  53. --disable-scrollkeeper \
  54. --disable-static \
  55. --disable-deprecations \
  56. --disable-desktop-docs
  57. # desktop-docs will be built by gnome-desktop:3
  58. }
  59. src_install() {
  60. DOCS="AUTHORS ChangeLog HACKING NEWS README"
  61. gnome2_src_install
  62. # python-r1.eclass doesn't like versioned python shebangs
  63. sed -e 's@#!\(.*python.*\)@#!/usr/bin/env python@' -i gnome-about/gnome-about
  64. python_doscript gnome-about/gnome-about
  65. }