libgnomeui-2.24.5-r1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. GNOME_TARBALL_SUFFIX="bz2"
  7. inherit gnome2
  8. DESCRIPTION="User Interface routines for Gnome"
  9. HOMEPAGE="https://library.gnome.org/devel/libgnomeui/stable/"
  10. LICENSE="LGPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
  13. IUSE="test"
  14. # gtk+-2.14 dep instead of 2.12 ensures system doesn't loose VFS capabilities in GtkFilechooser
  15. RDEPEND="
  16. dev-libs/atk
  17. >=dev-libs/glib-2.16:2
  18. >=dev-libs/libxml2-2.4.20:2
  19. >=dev-libs/popt-1.5
  20. >=gnome-base/gconf-2:2
  21. >=gnome-base/gnome-keyring-0.4
  22. >=gnome-base/gnome-vfs-2.7.3:2
  23. >=gnome-base/libgnome-2.13.7
  24. >=gnome-base/libgnomecanvas-2
  25. gnome-base/libgnome-keyring
  26. >=gnome-base/libbonoboui-2.13.1
  27. >=gnome-base/libglade-2:2.0
  28. media-libs/libart_lgpl
  29. x11-libs/gdk-pixbuf:2
  30. >=x11-libs/gtk+-2.14:2
  31. >=x11-libs/pango-1.1.2
  32. x11-libs/libICE
  33. x11-libs/libSM
  34. "
  35. DEPEND="${RDEPEND}
  36. dev-util/gtk-doc-am
  37. sys-devel/gettext
  38. virtual/pkgconfig
  39. >=dev-util/intltool-0.40
  40. "
  41. PDEPEND="x11-themes/adwaita-icon-theme"
  42. src_prepare() {
  43. if ! use test; then
  44. sed 's/ test-gnome//' -i Makefile.am Makefile.in || die "sed failed"
  45. fi
  46. gnome2_src_prepare
  47. }