gnome-integration-spotify-20140907.ebuild 925 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit gnome2-utils
  5. DESCRIPTION="GNOME integration for Spotify"
  6. HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
  7. #SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
  8. SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. #S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE=""
  14. DEPEND=""
  15. RDEPEND="${DEPEND}
  16. dev-lang/python
  17. dev-python/dbus-python
  18. media-gfx/imagemagick
  19. x11-misc/wmctrl
  20. x11-misc/xautomation
  21. x11-misc/xdotool
  22. x11-apps/xwininfo"
  23. src_install() {
  24. dobin spotify-dbus.py
  25. mkdir -p "${D}/etc/gconf/schemas"
  26. cp spotify.schemas "${D}/etc/gconf/schemas"
  27. }
  28. pkg_preinst() {
  29. gnome2_gconf_savelist
  30. }
  31. pkg_postinst() {
  32. gnome2_gconf_install
  33. }
  34. pkg_prerm() {
  35. gnome2_gconf_uninstall
  36. }