gucharmap-3.0.1-r200.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. GNOME_TARBALL_SUFFIX="bz2"
  6. inherit gnome2
  7. DESCRIPTION="Unicode character map viewer library"
  8. HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
  12. IUSE="cjk debug doc +introspection"
  13. RDEPEND="
  14. >=dev-libs/glib-2.16.3:2
  15. >=x11-libs/pango-1.2.1[introspection?]
  16. >=x11-libs/gtk+-2.14.0:2[introspection?]
  17. introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-util/gtk-doc-am
  21. >=dev-util/intltool-0.40
  22. sys-devel/gettext
  23. virtual/pkgconfig
  24. "
  25. src_prepare() {
  26. # .desktop and schema files are only needed for the gucharmap program
  27. sed -e 's:desktop_DATA\s*=.*:desktop_DATA = :' \
  28. -e 's:schema_DATA\s*=.*:schema_DATA = :' \
  29. -i Makefile.* || die "sed Makefile.* failed"
  30. eapply "${FILESDIR}/${PN}-3.4.1.1-fix-doc.patch" # bug 436710, fixed in 3.6
  31. gnome2_src_prepare
  32. }
  33. src_configure() {
  34. gnome2_src_configure \
  35. --disable-static \
  36. --with-gtk=2.0 \
  37. --disable-charmap \
  38. --disable-gconf \
  39. $(use_enable cjk unihan) \
  40. $(use_enable debug) \
  41. $(use_enable introspection)
  42. }
  43. pkg_postinst() {
  44. gnome2_pkg_postinst
  45. if ! has_version "gnome-extra/gucharmap:2.90" ; then
  46. ewarn "Note: ${PF} includes only the gucharmap-2 library."
  47. ewarn "If you need the gucharmap program, emerge gucharmap:2.90"
  48. fi
  49. }