gemas-0.4.ebuild 911 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils gnustep-2
  5. MY_P=${P/g/G}
  6. DESCRIPTION="a simple code editor for GNUstep"
  7. HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
  8. SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="projectcenter"
  13. DEPEND=">=gnustep-libs/highlighterkit-0.1.2
  14. >=virtual/gnustep-back-0.22.0
  15. projectcenter? ( gnustep-apps/projectcenter )"
  16. RDEPEND="${DEPEND}"
  17. S=${WORKDIR}/${MY_P}
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-bundle_makefile.patch
  20. }
  21. src_compile() {
  22. gnustep-base_src_compile
  23. if use projectcenter;
  24. then
  25. cd Bundle/Gemas || die "compile cd failed"
  26. egnustep_make
  27. fi
  28. }
  29. src_install() {
  30. gnustep-base_src_install
  31. if use projectcenter;
  32. then
  33. cd Bundle/Gemas || die "install cd failed"
  34. egnustep_install
  35. fi
  36. }