font-misc-ethiopic-1.0.3.ebuild 596 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=3
  4. FONT_DIR="OTF"
  5. inherit xorg-2
  6. DESCRIPTION="Miscellaneous Ethiopic fonts"
  7. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  8. IUSE=""
  9. RDEPEND=""
  10. DEPEND="${RDEPEND}
  11. x11-apps/bdftopcf"
  12. FONT_OPTIONS="--with-otf-fontdir=${EPREFIX}usr/share/fonts/OTF"
  13. src_install() {
  14. xorg-2_src_install
  15. # TTF fonts are not supposed to be installed.
  16. # Also fixes file collision per bug #309689
  17. rm -rf "${D}/${EPREFIX}usr/share/fonts/TTF"
  18. }