pcf2bdf-1.04-r1.ebuild 748 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs eutils
  4. DESCRIPTION="Converts PCF fonts to BDF fonts"
  5. HOMEPAGE="http://www.tsg.ne.jp/GANA/S/pcf2bdf/"
  6. SRC_URI="http://www.tsg.ne.jp/GANA/S/pcf2bdf/${P}.tgz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~ppc s390 sh sparc x86 ~x86-fbsd"
  10. IUSE=""
  11. S=${WORKDIR}
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}"/${P}-64bit.patch
  16. epatch "${FILESDIR}"/${P}-gzip.patch
  17. }
  18. src_compile() {
  19. emake -f Makefile.gcc CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" || die "emake failed"
  20. }
  21. src_install() {
  22. emake -f Makefile.gcc \
  23. PREFIX="${D}/usr" \
  24. MANPATH="${D}/usr/share/man/man1" \
  25. install || die
  26. }