cimg-1.7.8.ebuild 526 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PV=${PV//./}
  5. MY_P="CImg-v.${MY_PV}"
  6. DESCRIPTION="C++ template image processing toolkit"
  7. HOMEPAGE="http://cimg.eu/ https://github.com/dtschump/CImg"
  8. SRC_URI="https://github.com/dtschump/CImg/archive/v.${MY_PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="CeCILL-2 CeCILL-C"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc"
  13. S=${WORKDIR}/${MY_P}
  14. src_install() {
  15. dodoc README.txt
  16. doheader CImg.h
  17. use doc && dodoc -r html
  18. }