gupnp-dlna-0.10.4.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. VALA_USE_DEPEND="vapigen"
  7. inherit gnome2 vala
  8. DESCRIPTION="Library providing DLNA-related functionality for MediaServers"
  9. HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
  10. LICENSE="LGPL-2"
  11. SLOT="2.0"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  13. IUSE="+introspection"
  14. RDEPEND="
  15. >=dev-libs/glib-2.34:2
  16. >=dev-libs/libxml2-2.5:2
  17. media-libs/gstreamer:1.0
  18. media-libs/gst-plugins-base:1.0[introspection?]
  19. introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
  20. "
  21. DEPEND="${RDEPEND}
  22. >=dev-util/gtk-doc-am-1.11
  23. virtual/pkgconfig
  24. introspection? ( $(vala_depend) )
  25. "
  26. src_prepare() {
  27. # Make doc parallel installable
  28. cd "${S}"/doc/gupnp-dlna
  29. sed -e "s/\(DOC_MODULE.*=\).*/\1${PN}-${SLOT}/" \
  30. -e "s/\(DOC_MAIN_SGML_FILE.*=\).*/\1${PN}-docs-${SLOT}.sgml/" \
  31. -i Makefile.am Makefile.in || die
  32. sed -e "s/\(<book.*name=\"\)${PN}/\1${PN}-${SLOT}/" \
  33. -i html/${PN}.devhelp2 || die
  34. mv ${PN}-docs{,-${SLOT}}.sgml || die
  35. mv ${PN}-overrides{,-${SLOT}}.txt || die
  36. mv ${PN}-sections{,-${SLOT}}.txt || die
  37. mv ${PN}{,-${SLOT}}.types || die
  38. mv html/${PN}{,-${SLOT}}.devhelp2
  39. cd "${S}"
  40. use introspection && vala_src_prepare
  41. gnome2_src_prepare
  42. }
  43. src_configure() {
  44. gnome2_src_configure \
  45. --disable-static \
  46. $(use_enable introspection)
  47. }
  48. src_install() {
  49. # Parallel install fails, upstream bug #720053
  50. MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install
  51. }