jpeg-8d-r2.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # this ebuild is only for the libjpeg.so.8 SONAME for ABI compat
  5. inherit eutils libtool toolchain-funcs multilib-minimal
  6. DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
  7. HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
  8. SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz"
  9. LICENSE="IJG"
  10. SLOT="8"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  12. IUSE=""
  13. RDEPEND="!=media-libs/jpeg-8*:0
  14. !<media-libs/libjpeg-turbo-1.3.0-r2
  15. abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
  16. !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
  17. DEPEND="${RDEPEND}"
  18. DOCS=""
  19. src_prepare() {
  20. epatch \
  21. "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch \
  22. "${FILESDIR}"/${P}-CVE-2013-6629.patch
  23. elibtoolize
  24. }
  25. multilib_src_configure() {
  26. # Fix building against this library on eg. Solaris and DragonFly BSD, see:
  27. # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
  28. local ldverscript=
  29. [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
  30. ECONF_SOURCE=${S} \
  31. econf \
  32. --disable-static \
  33. --enable-maxmem=64 \
  34. ${ldverscript}
  35. }
  36. multilib_src_compile() {
  37. emake libjpeg.la
  38. }
  39. multilib_src_install() {
  40. newlib.so .libs/libjpeg.so.8.4.0 libjpeg.so.8
  41. }