libdvbpsi-0.2.1.ebuild 898 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
  5. HOMEPAGE="http://www.videolan.org/libdvbpsi"
  6. SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
  10. IUSE="doc static-libs"
  11. RDEPEND=""
  12. DEPEND="
  13. doc? (
  14. app-doc/doxygen
  15. >=media-gfx/graphviz-2.26
  16. )" # Require recent enough graphviz wrt #181147
  17. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  18. src_prepare() {
  19. sed -e '/CFLAGS/s:-O2::' -e '/CFLAGS/s:-O6::' -i configure || die
  20. }
  21. src_configure() {
  22. econf \
  23. $(use_enable static-libs static) \
  24. --enable-release
  25. }
  26. src_compile() {
  27. emake
  28. use doc && emake doc
  29. }
  30. src_install() {
  31. default
  32. use doc && dohtml doc/doxygen/html/*
  33. rm -f "${ED}"usr/lib*/${PN}.la
  34. }