libdvbpsi-1.3.0-r1.ebuild 971 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
  5. HOMEPAGE="http://www.videolan.org/libdvbpsi"
  6. SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
  7. LICENSE="LGPL-2.1"
  8. # Sublot == libdvbpsi.so major
  9. SLOT="0/10"
  10. KEYWORDS="alpha amd64 arm ~arm64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
  11. IUSE="doc static-libs"
  12. RDEPEND=""
  13. DEPEND="
  14. doc? (
  15. app-doc/doxygen
  16. >=media-gfx/graphviz-2.26
  17. )" # Require recent enough graphviz wrt #181147
  18. DOCS=( AUTHORS ChangeLog NEWS README )
  19. src_prepare() {
  20. sed -e '/CFLAGS/s:-O2::' -e '/CFLAGS/s:-O6::' -e '/CFLAGS/s:-Werror::' -i configure || die
  21. }
  22. src_configure() {
  23. econf \
  24. $(use_enable static-libs static) \
  25. --enable-release
  26. }
  27. src_compile() {
  28. emake
  29. use doc && emake doc
  30. }
  31. src_install() {
  32. default
  33. use doc && dohtml doc/doxygen/html/*
  34. rm -f "${ED}"usr/lib*/${PN}.la
  35. }