libggimisc-2.2.2.ebuild 760 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="Library for General Graphics Interface"
  4. HOMEPAGE="http://www.ggi-project.org"
  5. SRC_URI="mirror://sourceforge/ggi/${P}.src.tar.bz2"
  6. LICENSE="MIT"
  7. SLOT="0"
  8. KEYWORDS="amd64 ~x86"
  9. IUSE="fbcon svga"
  10. RDEPEND=">=media-libs/libggi-2.2.2
  11. svga? ( media-libs/svgalib )"
  12. DEPEND="${RDEPEND}"
  13. src_compile() {
  14. econf --disable-x --without-x \
  15. $(use_enable svga svgalib) \
  16. $(use_enable fbcon fbdev)
  17. emake || die "emake failed."
  18. }
  19. src_install() {
  20. emake DESTDIR="${D}" install || die "emake install failed."
  21. dodoc ChangeLog README TODO doc/*.txt
  22. }
  23. pkg_postinst() {
  24. elog "X extension for ${PN} has been temporarily disabled for this release."
  25. }