libmediaart-0.7.0.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. VALA_USE_DEPEND="vapigen"
  6. VALA_MIN_API_VERSION="0.16"
  7. inherit autotools gnome2 vala virtualx
  8. DESCRIPTION="Manages, extracts and handles media art caches"
  9. HOMEPAGE="https://github.com/GNOME/libmediaart"
  10. LICENSE="LGPL-2.1+"
  11. SLOT="1.0"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  13. IUSE="gtk +introspection qt4 qt5 vala"
  14. REQUIRED_USE="
  15. ?? ( gtk qt4 qt5 )
  16. vala? ( introspection )
  17. "
  18. RDEPEND="
  19. >=dev-libs/glib-2.38.0:2
  20. gtk? ( >=x11-libs/gdk-pixbuf-2.12:2 )
  21. introspection? ( >=dev-libs/gobject-introspection-1.30 )
  22. qt4? ( dev-qt/qtgui:4 )
  23. qt5? ( dev-qt/qtgui:5 )
  24. "
  25. DEPEND="${RDEPEND}
  26. >=dev-util/gtk-doc-am-1.8
  27. virtual/pkgconfig
  28. vala? ( $(vala_depend) )
  29. "
  30. src_prepare() {
  31. use vala && vala_src_prepare
  32. epatch "${FILESDIR}/${P}-qt5.patch" #523122
  33. eautoreconf
  34. gnome2_src_prepare
  35. }
  36. src_configure() {
  37. local myconf=""
  38. if use qt4 ; then
  39. myconf="${myconf} --enable-qt --with-qt-version=4"
  40. elif use qt5 ; then
  41. myconf="${myconf} --enable-qt --with-qt-version=5"
  42. else
  43. myconf="${myconf} --disable-qt"
  44. fi
  45. gnome2_src_configure \
  46. --enable-unit-tests \
  47. $(use_enable gtk gdkpixbuf) \
  48. $(use_enable introspection) \
  49. $(use_enable vala) \
  50. ${myconf}
  51. }
  52. src_test() {
  53. dbus-launch Xemake check #513502
  54. }