libmypaint-1.3.0_beta1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-any-r1 xdg-utils toolchain-funcs
  6. MY_PV=${PV/_beta/-beta.}
  7. MY_P=${PN}-${MY_PV}
  8. DESCRIPTION="Library for making brushstrokes"
  9. HOMEPAGE="https://github.com/mypaint/libmypaint"
  10. SRC_URI="https://github.com/mypaint/libmypaint/releases/download/v${MY_PV}/${MY_P}.tar.xz"
  11. LICENSE="ISC"
  12. SLOT="0/0" # first soname component for subslot
  13. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
  14. IUSE="gegl introspection nls openmp"
  15. CDEPEND="
  16. dev-libs/glib:2
  17. dev-libs/json-c
  18. gegl? (
  19. media-libs/babl
  20. media-libs/gegl:0.3[introspection?]
  21. )
  22. introspection? ( >=dev-libs/gobject-introspection-1.32 )
  23. openmp? ( sys-devel/gcc:*[openmp] )
  24. nls? ( sys-devel/gettext )
  25. "
  26. DEPEND="${CDEPEND}
  27. ${PYTHON_DEPS}
  28. nls? ( dev-util/intltool )
  29. "
  30. RDEPEND="${CDEPEND}
  31. !<media-gfx/mypaint-1.2.2
  32. "
  33. S="${WORKDIR}"/${MY_P}
  34. src_prepare() {
  35. xdg_environment_reset
  36. epatch "${FILESDIR}"/${PN}-1.3.0_beta1-as-needed.patch
  37. eapply_user
  38. }
  39. src_configure() {
  40. tc-ld-disable-gold # bug 589266
  41. econf \
  42. --disable-debug \
  43. --disable-docs \
  44. $(use_enable gegl) \
  45. --disable-gperftools \
  46. $(use_enable nls i18n) \
  47. $(use_enable introspection) \
  48. $(use_enable openmp) \
  49. --disable-profiling
  50. }