liboggz-1.1.1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit autotools eutils
  5. DESCRIPTION="Oggz provides a simple programming interface for reading and writing Ogg files and streams"
  6. HOMEPAGE="http://www.xiph.org/oggz/"
  7. SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
  11. IUSE="doc static-libs test"
  12. RDEPEND=">=media-libs/libogg-1.2.0"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. doc? ( app-doc/doxygen )
  16. test? ( app-text/docbook-sgml-utils )"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-destdir.patch
  19. if ! use doc; then
  20. sed -i -e '/AC_CHECK_PROG/s:doxygen:dIsAbLe&:' configure.ac || die
  21. fi
  22. AT_M4DIR="m4" eautoreconf
  23. }
  24. src_configure() {
  25. econf \
  26. --disable-dependency-tracking \
  27. $(use_enable static-libs static)
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die
  31. dodoc AUTHORS ChangeLog README TODO
  32. find "${D}" -name '*.la' -delete
  33. }