openctm-1.0.3.ebuild 861 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib versionator flag-o-matic
  5. MY_PV=OpenCTM-${PV}
  6. DESCRIPTION="OpenCTM - the Open Compressed Triangle Mesh."
  7. HOMEPAGE="http://openctm.sourceforge.net"
  8. SRC_URI="mirror://debian/pool/main/o/${PN}/${PN}_${PV}+dfsg1.orig.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="dev-libs/tinyxml
  14. media-libs/freeglut
  15. media-libs/glew
  16. media-libs/pnglite
  17. virtual/opengl
  18. x11-libs/gtk+:2"
  19. RDEPEND="${DEPEND}"
  20. S="${WORKDIR}/${MY_PV}"
  21. src_prepare() {
  22. epatch \
  23. "${FILESDIR}"/openctm-fix-makefiles.patch \
  24. "${FILESDIR}"/openctm-no-strip.patch
  25. mv Makefile.linux Makefile || die
  26. sed \
  27. -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" \
  28. -i Makefile || die
  29. }
  30. src_compile() {
  31. emake CC=$(tc-getCC) CXX=$(tc-getCXX)
  32. }