quarter-1.0.0-r1.ebuild 992 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils flag-o-matic
  5. MY_P="${P/q/Q}"
  6. DESCRIPTION="A glue between Nokia Qt4 and Coin3D"
  7. HOMEPAGE="http://www.coin3d.org/lib/quarter"
  8. SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86"
  11. SLOT="0"
  12. IUSE="debug doc static-libs"
  13. RDEPEND="
  14. >=media-libs/coin-3.0.0[javascript]
  15. dev-qt/designer:4
  16. dev-qt/qtcore:4
  17. dev-qt/qtgui:4
  18. dev-qt/qtopengl:4
  19. virtual/opengl
  20. "
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig
  23. doc? ( app-doc/doxygen )
  24. "
  25. S="${WORKDIR}/${MY_P}"
  26. PATCHES=(
  27. "${FILESDIR}/${P}-gcc44.patch"
  28. )
  29. DOCS=(AUTHORS NEWS README)
  30. src_configure() {
  31. append-libs -lGL #369967, library calls glEnable()
  32. local myeconfargs=(
  33. htmldir="${ROOT}usr/share/doc/${PF}/html"
  34. --enable-pkgconfig
  35. --with-coin
  36. $(use_enable debug)
  37. $(use_enable debug symbols)
  38. $(use_enable doc html)
  39. )
  40. autotools-utils_src_configure
  41. }