soxr-0.1.1.ebuild 731 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-multilib
  5. MY_P=${P}-Source
  6. DESCRIPTION="The SoX Resampler library"
  7. HOMEPAGE="https://sourceforge.net/p/soxr/wiki/Home/"
  8. SRC_URI="mirror://sourceforge/soxr/${MY_P}.tar.xz"
  9. LICENSE="LGPL-2.1"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd"
  12. IUSE="examples"
  13. DEPEND=""
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}/${MY_P}"
  16. DOCS=( "README" "TODO" "NEWS" "AUTHORS" )
  17. PATCHES=(
  18. "${FILESDIR}/nodoc.patch"
  19. "${FILESDIR}/noexamples.patch"
  20. )
  21. src_install() {
  22. cmake-multilib_src_install
  23. if use examples ; then
  24. dodoc -r examples
  25. docompress -x /usr/share/doc/${PF}/examples
  26. fi
  27. }