spandsp-0.0.6_pre21.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit multilib versionator
  5. DESCRIPTION="SpanDSP is a library of DSP functions for telephony"
  6. HOMEPAGE="http://www.soft-switch.org/"
  7. SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
  11. IUSE="doc fixed-point cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 static-libs"
  12. RDEPEND="media-libs/tiff"
  13. DEPEND="${RDEPEND}
  14. doc? ( app-doc/doxygen
  15. dev-libs/libxslt )"
  16. S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
  17. # TODO:
  18. # there are two tests options: tests and test-data
  19. # they need audiofile, fftw, libxml and probably more
  20. # configure script is auto-enabling some sse* options sometimes
  21. src_configure() {
  22. econf \
  23. --disable-dependency-tracking \
  24. $(use_enable doc) \
  25. $(use_enable fixed-point) \
  26. $(use_enable cpu_flags_x86_mmx mmx) \
  27. $(use_enable cpu_flags_x86_sse2 sse2) \
  28. $(use_enable cpu_flags_x86_sse3 sse3) \
  29. $(use_enable static-libs static)
  30. }
  31. src_install () {
  32. emake DESTDIR="${D}" install
  33. dodoc AUTHORS ChangeLog DueDiligence NEWS README
  34. if ! use static-libs; then
  35. # remove useless la file when not installing static lib
  36. rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
  37. fi
  38. if use doc; then
  39. dohtml -r doc/{api/html/*,t38_manual}
  40. fi
  41. }