mediastreamer-amr-0.0.1.ebuild 671 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib
  5. MY_P="msamr-${PV}"
  6. DESCRIPTION="mediastreamer plugin: add AMR Narrow Band support"
  7. HOMEPAGE="http://www.linphone.org/"
  8. SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc ppc64 x86"
  12. IUSE=""
  13. RDEPEND=">=media-libs/mediastreamer-2.0.0:=
  14. >=media-libs/opencore-amr-0.1.2"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. S=${WORKDIR}/${MY_P}
  18. src_prepare() {
  19. epatch "${FILESDIR}/${P}-include.patch"
  20. }
  21. src_configure() {
  22. # strict: don't want -Werror
  23. econf \
  24. --disable-strict
  25. }