mediastreamer-bcg729-1.0.0-r1.ebuild 569 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_P="bcg729-${PV}"
  5. DESCRIPTION="Backported G729 implementation for Linphone"
  6. HOMEPAGE="http://www.linphone.org"
  7. SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=media-libs/mediastreamer-2.8.2:=[ortp]"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. S="${WORKDIR}/${MY_P}"
  16. src_configure(){
  17. # strict = -Werror
  18. econf \
  19. --disable-static \
  20. --disable-strict
  21. }