swh-lv2-1.0.15.ebuild 696 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit toolchain-funcs multilib
  5. DESCRIPTION="Large collection of LV2 audio plugins/effects"
  6. HOMEPAGE="http://plugin.org.uk/"
  7. SRC_URI="http://plugin.org.uk/lv2/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="=sci-libs/fftw-3*"
  13. DEPEND="${RDEPEND}
  14. dev-libs/libxslt
  15. virtual/pkgconfig"
  16. src_prepare() {
  17. sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
  18. -i Makefile || die
  19. }
  20. src_compile() {
  21. emake CC=$(tc-getCC) || die
  22. }
  23. src_install() {
  24. emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die
  25. dodoc README
  26. }