swh-lv2-1.0.16.ebuild 751 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Large collection of LV2 audio plugins/effects"
  6. HOMEPAGE="http://plugin.org.uk/"
  7. SRC_URI="https://github.com/swh/lv2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="sci-libs/fftw:3.0"
  13. DEPEND="${RDEPEND}
  14. dev-libs/libxslt
  15. virtual/pkgconfig"
  16. S="${WORKDIR}/lv2-${PV}"
  17. src_prepare() {
  18. sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
  19. -i Makefile || die
  20. default
  21. }
  22. src_compile() {
  23. emake CC=$(tc-getCC) || die
  24. }
  25. src_install() {
  26. emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die
  27. dodoc README
  28. }