vdr-avards-0.2.4.ebuild 838 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit vdr-plugin-2
  5. DESCRIPTION="VDR Plugin: Automatic Video Aspect Ratio Detection and Signaling"
  6. HOMEPAGE="http://firefly.vdr-developer.org/avards/"
  7. SRC_URI="http://firefly.vdr-developer.org/avards/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND=">=media-video/vdr-1.6.0"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. vdr-plugin-2_src_prepare
  16. sed -i "s:i18n.c:i18n.h:g" Makefile
  17. if ! has_version ">=media-video/vdr-1.7.13"; then
  18. sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile
  19. fi
  20. # fix deprecated i18n handling >=vdr-1.7.27
  21. sed -i "s:i18n.o::" Makefile || die "sed makefile faild"
  22. sed -i "s:extern://extern:" i18n.h || die "sed i18n.h failed"
  23. }