dxcc-20080225-r1.ebuild 513 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A ham radio callsign DXCC lookup utility"
  6. HOMEPAGE="http://fkurz.net/ham/dxcc.html"
  7. SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="tk"
  12. RDEPEND="dev-lang/perl
  13. tk? ( dev-perl/Tk )"
  14. src_prepare() {
  15. epatch "${FILESDIR}/Makefile.patch"
  16. }
  17. src_install() {
  18. emake DESTDIR="${D}/usr" install
  19. dodoc README ChangeLog
  20. }