xwxapt-2.7.ebuild 1000 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
  6. HOMEPAGE="http://www.qsl.net/5b4az/pages/apt.html"
  7. SRC_URI="http://www.qsl.net/5b4az/pkg/apt/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. net-wireless/rtl-sdr
  14. media-libs/alsa-lib
  15. dev-libs/glib:2
  16. x11-libs/gtk+:2"
  17. DEPEND="${RDEPEND}
  18. sys-devel/gettext
  19. virtual/pkgconfig"
  20. src_prepare() {
  21. # create missing mkinstalldir and prepare package
  22. glib-gettextize --force --copy || die "gettextize failed"
  23. eautoreconf
  24. }
  25. src_install() {
  26. default
  27. dohtml doc/xwxapt.html
  28. insinto /usr/share/${PN}
  29. doins xwxapt/xwxaptrc
  30. dodir /usr/share/${PN}/images /usr/share/${PN}/records
  31. }
  32. pkg_postinst() {
  33. einfo "You must copy the /usr/share/xwxapt directory into your home directory"
  34. einfo "and configure the contained xwxaptrc file before starting the program"
  35. }