asfrecorder-1.1.ebuild 811 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. MY_PN="${PN/asfr/ASFR}"
  6. DESCRIPTION="ASFRecorder - Download Windows Media Streaming files"
  7. HOMEPAGE="https://sourceforge.net/projects/asfrecorder/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.zip"
  9. LICENSE="public-domain"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos"
  12. IUSE=""
  13. DEPEND="app-arch/unzip"
  14. S=${WORKDIR}/${MY_PN}
  15. src_compile() {
  16. # There is a Makefile, but it only works for Cygwin, so we
  17. # only compile this single program.
  18. cd "${S}"/source
  19. $(tc-getCC) -o asfrecorder ${CFLAGS} ${LDFLAGS} asfrecorder.c || die "Build failed"
  20. }
  21. src_install () {
  22. # Again, no makefiles, so just take what we want.
  23. dobin source/asfrecorder
  24. dodoc README.TXT
  25. }