argus-clients-3.0.8.2.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils toolchain-funcs
  5. DESCRIPTION="Clients for net-analyzer/argus"
  6. HOMEPAGE="http://www.qosient.com/argus/"
  7. SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="debug ft geoip mysql sasl tcpd"
  12. MY_CDEPEND="
  13. net-analyzer/rrdtool[perl]
  14. net-libs/libpcap
  15. sys-libs/ncurses:=
  16. sys-libs/readline:=
  17. sys-libs/zlib
  18. ft? ( net-analyzer/flow-tools )
  19. geoip? ( dev-libs/geoip )
  20. mysql? ( virtual/mysql )
  21. sasl? ( dev-libs/cyrus-sasl )
  22. "
  23. RDEPEND="
  24. ${MY_CDEPEND}
  25. "
  26. DEPEND="
  27. ${MY_CDEPEND}
  28. sys-devel/bison
  29. sys-devel/flex
  30. virtual/pkgconfig
  31. "
  32. src_prepare() {
  33. epatch \
  34. "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch \
  35. "${FILESDIR}"/${PN}-3.0.7.21-curses-readline.patch
  36. sed -i -e 's| ar | $(AR) |g' common/Makefile.in || die
  37. tc-export AR RANLIB
  38. eautoreconf
  39. }
  40. src_configure() {
  41. use debug && touch .debug
  42. econf \
  43. $(use_with ft libft) \
  44. $(use_with geoip GeoIP /usr/) \
  45. $(use_with sasl) \
  46. $(use_with tcpd wrappers) \
  47. $(use_with mysql)
  48. }
  49. src_compile() {
  50. # racurses uses both libncurses and libtinfo, if present
  51. emake \
  52. CCOPT="${CFLAGS} ${LDFLAGS}" \
  53. RANLIB=$(tc-getRANLIB) \
  54. CURSESLIB="$( $(tc-getPKG_CONFIG) --libs ncurses)"
  55. }
  56. src_install() {
  57. dobin bin/ra*
  58. dodoc ChangeLog CREDITS README CHANGES
  59. doman man/man{1,5}/*
  60. }