egressor-1.0-r2.ebuild 779 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="tool for checking router configuration"
  6. HOMEPAGE="http://packetfactory.openwall.net/projects/egressor/"
  7. SRC_URI="${HOMEPAGE}${PN}_release${PV}.tar.gz"
  8. LICENSE="egressor"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. DEPEND="<net-libs/libnet-1.1
  12. >=net-libs/libnet-1.0.2a-r3"
  13. RDEPEND="net-libs/libpcap
  14. dev-perl/Net-RawIP
  15. dev-lang/perl"
  16. S=${WORKDIR}
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${PV}-libnet-1.0.patch \
  20. "${FILESDIR}"/${PV}-flags.patch
  21. }
  22. src_compile() {
  23. tc-export CC
  24. emake -C client
  25. }
  26. src_install() {
  27. dobin client/egressor server/egressor_server.pl
  28. dodoc README client/README-CLIENT server/README-SERVER
  29. }