fe3d-0.11.2.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WX_GTK_VER="2.8"
  5. inherit autotools eutils wxwidgets
  6. if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
  7. inherit subversion
  8. SRC_URI=""
  9. FE3D_REV=${BASH_REMATCH[2]}
  10. ESVN_REPO_URI="http://svn.icapsid.net/fe3d/fe3d/branches/fe3d_0.11/@${FE3D_REV}"
  11. else
  12. SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}-src.tar.bz2"
  13. fi
  14. DESCRIPTION="A 3D visualization tool for network security information"
  15. HOMEPAGE="http://projects.icapsid.net/fe3d/"
  16. LICENSE="GPL-2"
  17. SLOT="0"
  18. KEYWORDS="~alpha amd64 x86"
  19. DOCS=( AUTHORS doc/{ChangeLog,README}.txt )
  20. RDEPEND="
  21. >=dev-libs/xerces-c-2.7
  22. net-analyzer/nmap
  23. x11-libs/wxGTK:2.8[opengl]
  24. "
  25. DEPEND="${RDEPEND}"
  26. S=${WORKDIR}/${PN}_${PV}
  27. src_prepare() {
  28. need-wxwidgets unicode
  29. epatch \
  30. "${FILESDIR}"/${P}-asneeded.patch \
  31. "${FILESDIR}"/${P}-coreutils.patch
  32. eautoreconf
  33. }
  34. pkg_postinst() {
  35. ewarn "This package has known issues:"
  36. ewarn "1. The radius of the geometry nodes is wrong, causing overlap"
  37. ewarn "2. Earth (and other) textures are upside down"
  38. ewarn "3. This package contains some minor memory leaks"
  39. echo
  40. elog "Example using a nmap log:"
  41. elog "/usr/bin/nmap -oX test.xml -O --osscan_limit 192.168.0.0/24"
  42. elog "/usr/bin/fe3d test.xml"
  43. }