flent-1.0.1.ebuild 676 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
  5. inherit distutils-r1
  6. DESCRIPTION="The FLExible Network Tester"
  7. HOMEPAGE="https://flent.org/"
  8. SRC_URI="https://github.com/tohojo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="+qt5 qt4 +plots"
  13. RDEPEND="qt4? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
  14. qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
  15. plots? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
  16. net-analyzer/netperf[demo]
  17. net-misc/iperf
  18. net-analyzer/fping"
  19. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"